Aquaponic Gardening

A Community and Forum For Aquaponic Gardeners

So I've setup a new AP system in my apartment been running it for about 2 weeks now and now I've run into a small delima. With my experience with fish if my tanks smelled all I would do is a partial water change and that was that. I'm new to AP so my tank and the grow bed smell a little but If I do a water change wouldn't I be robbing my system of nutrients? Need help on what I should do to control the smell or is it just because it's to early for balance?

Views: 748

Reply to This

Replies to This Discussion

In general, if there is a smell, something is wrong.

What kind of smell are you experiencing?

Now if you have a really sensitive sniffer, make sure you are not simply smelling the fish food.

Are you growing any plants with a strong odor?  Some people might not enjoy growing indoor onions.

What do your water tests say?  This is the big one for determining if you have a good balance.

What type of system is it?  Flood and drain?  Constant flood media?  Raft?  NFT? Something else?

Only places I've really experienced problematic odors from an aquaponics system have been when I tried NFT without filtering the water first (the fish poo would build up against the plant roots and become very nasty, I mean gag a person with a really strong stomach nasty.)  Or if you are doing constant flood media with very minimal flow, especially if the top of the gravel is wet and growing lots of algae, sometimes that will give a stronger odor that one would like indoors.

And the most likely area where you would run into an issue is if you don't have enough flow and aeration, anoxic or anaerobic areas in a system can give you quite the "pond bottom" odor so for an indoor system you will want to make sure you have plenty of flow through your tank and beds and if that isn't keeping the pond muck odor away you might need to add supplemental aeration.

It smells like you have something fishy going on...

It's a constant flood media.I just switched the pump in the system it was a 45gph pump and now Im using a pump from my larger tank at 500gph but I'm able to adjust the flow with a valve in the plumbing. The flow shouldn't be the issue right? I used a very matured fish tanks water to cycle the new setup to kickstart it. I also planted more plants in yesterday to see if it was just too much nutrients and not enough plants. My ph is @ 7.2 nitrites @ 10 ppm , nitrates @ 20 ppm and ammonia barely any. But the smell isn't there at the moment maybe it was just the initial ammonia spike from the mature water into the new system. But I'll update for the next week.

Nitrites at 10 ppm??!?!?!?!  Are there any fish in there?  eek

With the Nitrites high, perhaps you did just get past the ammonia spike.

45 gph probably wasn't enough.  Hopefully with the bigger pump now things will be better.  I would recommend having some air movement like a small fan which will also help the plants in an indoor set up.

Sorry meant .10 mg/l. Lol

ok, had me worried.

changing to water in your system would set you back to the beginning. remember that your system will have hardly got working (nutrient cycling) at this point in time. not sure what your system is like but it could be not enough bio-filtration and your water cycling speed is incorrect. do you have some dead fish somewhere? lastly, what is your storage medium? i have come across totes, plastic barrels and containers that smell really strong & bad.

Reply to Discussion

RSS

© 2020   Created by Sylvia Bernstein.   Powered by

Badges  |  Report an Issue  |  Terms of Service